Select your country or region: Stay on current site Select another site

logo

我的荣耀 开启荣耀之旅

打开
App 内打开

Ripples or stripes appear on the viewfinder or photo when I take a photo of a screen

Ripples or stripes appear on the viewfinder or photo when I take a photo of a screen

Problem:

Ripples or stripes appear in the viewfinder or photo when the user takes a photo of an OLED phone screen, computer screen, or TV screen.

Cause:

Some OLED screens adjust brightness through the pulse-width modulation (PWM) method. This means that the screen backlight turns on and off continuously at a high frequency, which is imperceptible to the human eye but can be captured by the camera. The following image uses an OLED phone screen as an example:
  • When the screen brightness is 40%, the backlight is in a 40% duty cycle, meaning that the screen is refreshed with 40% bright bars and 60% dark bars each time. As the camera captures the dark bars, ripples or stripes appear in the viewfinder or photos.

  • When the screen is at full brightness, the backlight is in a 100% duty cycle, meaning that the screen is refreshed with 100% bright bars each time. In this case, no ripples or stripes appear in the viewfinder or photos.
  • When the screen is set to the minimum brightness, the backlight is in a 0% duty cycle, meaning that the screen is refreshed with 100% dark bars each time. In this case, the screen is black.

Solution:

This is a normal phenomenon and does not affect the normal use of your phone. HONOR phones use industry-leading OLED screens and cameras, and undergo rigorous testing before shipment to ensure that they meet all applicable quality standards.

Suggestions:

  • Before taking a photo of a phone's OLED screen, set the screen to the maximum brightness.
  • When shooting a phone's OLED screen, you can turn on screen anti-flicker in Eye comfort on the other phone to reduce screen flicker.
  • To capture content on the phone screen, it is recommended that you use the screenshot function instead.

微信扫描二维码分享文章

Thank you for helping us grow better!
Your response has been submitted successfully!