Computer Fails to Scan Hotspot Signal and Connect to Hotspot When Connecting to the WLAN
Computer Fails to Scan Hotspot Signal and Connect to Hotspot When Connecting to the WLAN |
Problem 1
The computer fails to scan relevant hotspot signals when connecting to the WLAN.
Problem 2
The computer fails to connect to the hotspot, cannot connect to the network, or is easily disconnected from the network.
Cause
A small earth icon is displayed for the WLAN icon, but the computer cannot scan hotspots. Due to a time difference between the time refresh period of the operating system, the time refresh period of the underlying driver, and the time refresh period of the wireless hotspot, the hotspot cannot be scanned quickly.
Solution 1
- Hotspot cannot be scanned: Restart the wireless router and disable the WLAN driver. The procedure is as follows:
- Click the WLAN icon and choose Network & Internet settings > Network and Sharing Center > Change Adapter Settings.Right-click WLAN click Disable device, right-click WLAN and click Enable device.
- Set the value of MIMO Power Save Mode of WLAN to No SMPS. (This function is only available for products using Intel network adapter chips.) The procedure is as follows:
- Click the WLAN icon and choose Network & Internet settings > Network and Sharing Center > Change Adapter Settings.
- Right click the WLAN, select Properties, and click Configure.
- Click Properties and select Advanced. On the displayed page, click MIMO Power Save Mode, set Value to No SMPS, and then click OK. (Note: The network will be disconnected in this step.)
- Click the WLAN icon and choose Network & Internet settings > Network and Sharing Center > Change Adapter Settings.Right-click WLAN click Disable device, right-click WLAN and click Enable device.
Solution 2
The computer fails to connect to the hotspot, cannot connect to the network, or is easily disconnected from the network.
- Click the WLAN icon and choose Network & Internet settings > WLAN > Manage known networks. After selecting the hotspot, click Forget, reconnect the hotspot, and enter the correct password.
How to determine whether the password is correct: If you forget the WLAN password of the mobile phone or other devices, click Forget, and re-enter the password to check whether the password is correct.
- If the network is disconnected immediately or is easily disconnected, check whether the computer is connected to the mobile hotspot or other wireless routers normally. If the connection is normal, the router may be old. Try to configure the router according to step c. If there is still a problem after the configuration, replace the wireless router or use a wired connection to the network.
- Set the value of MIMO Power Save Mode of WLAN to No SMPS. For details, see step b of solution 1.
- Set the WLAN power option to high performance mode to increase the computer acceptance capability. The procedure is as follows:
- Open Control Panel. Click Hardware and Sound, and select Power Options.
- On the Power Options page, select Change plan settings.
- Click Change Advanced Power Settings (C).
- Choose Wireless Adapter Settings > Power Saving Mode, and change On battery and Plugged in to Maximum Performance.
- Open Control Panel. Click Hardware and Sound, and select Power Options.