Eine Drittanbieter-Fitness-App funktioniert nicht ordnungsgemäß
Eine Drittanbieter-Fitness-App funktioniert nicht ordnungsgemäß |
Problem:
Auf Honor-Telefonen, die die Schrittzähler-Funktion unterstützen, zählt eine Drittanbieter-Gesundheits-App keine Schritte, zählt Schritte ungenau oder verfolgt den Streckenverlauf ungenau.
Ursache:
Die entsprechende App wird von Ihrem Telefon gestoppt, wenn sie im Hintergrund ausgeführt wird.
Lösung:
- Aktualisieren Sie Ihr Telefon und die App auf die neueste Version.
- Gehen Sie wie folgt vor, um zu vermeiden, dass die App gestoppt wird, wenn sie im Hintergrund ausgeführt wird:
- Legen Sie fest, dass die App im Hintergrund ausgeführt werden darf:
- Öffnen Sie Einstellungen, suchen Sie nach Starten und greifen Sie darauf zu, schalten Sie den Automatisch verwalten-Schalter für die entsprechende App aus und wählen Sie Im Hintergrund ausführen im Eingabeaufforderungsfenster.
- Bestätigen Sie, dass die App bei Wirksamwerden der Akku-Optimierungsfunktion des Telefons ignoriert wird:
- Öffnen Sie Einstellungen, suchen Sie nach Akku-Optimierungen ignorieren und greifen Sie darauf zu. Tippen Sie auf den Abwärtspfeil neben Nicht zulassen, tippen Sie auf Alle Apps, suchen Sie nach der App und tippen Sie darauf und wählen Sie Nicht zulassen.
- Navigieren Sie zu Stromsparen und Ultra-Stromsparen. und deaktivieren Sie
- Legen Sie fest, dass die App im Hintergrund ausgeführt werden darf:
- Navigieren Sie zum Bildschirm „Zuletzt verwendete Aufgaben“ und sperren Sie die entsprechende App, um zu verhindern, dass sie während der Ausführung im Hintergrund gestoppt wird. Streichen Sie hierzu auf der App-Vorschau nach unten oder tippen Sie auf das Sperr-Symbol oben auf der App-Vorschau, je nach Systemversion Ihres Telefons.