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Wi-Fi repeatedly connects and disconnects

Wi-Fi repeatedly connects and disconnects

Problem

  1. Wi-Fi frequently disconnects and then automatically reconnects.
  2. The computer cannot automatically connect to the Wi-Fi network after the Wi-Fi connection interrupts.

Cause

  1. This issue may be caused by an issue with Wi-Fi roaming. If there are several mobile hotspots stored on the computer, the computer will automatically connect to the Wi-Fi hotspot with the best signal. If you frequently move the computer to other areas, the computer will frequently and automatically connect to other Wi-Fi hotspots.
  2. This issue may also occur when there are two hotspots (for example, one is 2.4 GHz and the other is 5 GHz) with the same network name and password. In this case, your computer will connect automatically to the Wi-Fi hotspot with the best signal and network connection.
  3. This issue may occur when the computer sends a data packet to the router and the router does not respond. In this case, the computer may think that the router is turned off and will then disconnect from it.
  4. This issue may also be caused by a faulty Wi-Fi driver.
  5. The router is too close to the computer and the signal is too strong.

Solution

  1. Only save one hotspot on your computer.
  2. Set different names for the 2.4 GHz and 5 GHz Wi-Fi hotspots on the router.
  3. Connect your computer to another hotspot, or restart the router and check whether this issue is resolved.
  4. If this issue persists, this issue may be caused by a faulty Wi-Fi driver. It is recommended that you reset the network. To do this, perform the following:

    Click the network icon on the taskbar and go to Network & Internet settings > Network reset > Reset now.

  5. If the issue persists, download the latest version of the Wi-Fi driver from the official website and install the new driver.
  6. Adjust the distance between the computer and the router so that they are more than 2 meters away from each other, and then reconnect the computer to the router.
  7. If the issue persists, back up important data, press and hold the power button to power on your computer, and then press and hold F10 to restore your phone to its factory settings. If this issue still cannot be resolved, back up important data, then bring your computer, proof of purchase, and warranty card to an authorized HONOR Customer Service Center for assistance.

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